StrategoXT 0.12 Installation Instructions

Download the required packages

First of all download the required packages (.tar.gz, RPMs or Source RPMs). You need aterm 2.2 and sdf2-bundle 2.2 The URLs are specified in the the release page of StrategoXT 0.12.

Using source tarballs

Use the instructions in this section if you want to install StrategoXT using source tarballs (.tar.gz). All packages can be installed using the usual configure, make, make install, so if you are familiar with installing tarballs there is nothing special about installing StrategoXT and its dependencies.

Installation of aterm and sdf2-bundle

The following sequence of commands takes care of building and installing the aterm and the sdf2-bundle in /usr/local.

tar zxf aterm-2.2.tar.gz
cd aterm-2.1
./configure --with-gcc
make install
cd ..

tar zxf sdf2-bundle-2.2.tar.gz
cd sdf2-bundle-2.2
make install
cd ..
Configuring the aterm library --with-gcc limits the number of different aterm libraries that are installed. Just installing the gcc version makes installation of the aterm library more portable and is sufficient for StrategoXT.

If you want to install the packages at a different location, you should specify a --prefix in the configure command. If you want to install the packages at two different locations, you must configure the sdf2-bundle with the location prefix aterm. For example:

./configure --prefix=/opt/aterm --with-gcc
./configure --prefix=/opt/sdf2-bundle --with-aterm=/opt/aterm

Installation of StrategoXT

Unpack, configure, make and install StrategoXT using the following commands:

tar zxf strategoxt-0.12.tar.gz
cd strategoxt-0.12
make install

If you want to install StrategoXT at a different prefix, you should specify a --prefix. If you installed the aterm library and the sdf2-bundle at a different location, you should specify their location using --with-aterm and --with-sdf. For example:

./configure --prefix=/opt/strategoxt \
  --with-aterm=/opt/aterm --with-sdf=/opt/sdf2-bundle

Using source RPMs


Using binary RPMs

Install the RPMs by running the following command in the directory where you've downloaded the RPMs.

rpm -i *

Use the upgrade option if you've already installed earlier versions of RPMs for aterm, strategoxt or the sdf2-bundle.

rpm -U *
Of course you can also install the RPMs one by one by specifying the filenames of the RPMs.

Related topics